99 f350 rough idle lack of power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-13-2008, 09:06 PM Thread Starter
Powerstroke.org Rookie
 
99strokeit's Avatar
 
Join Date: Feb 2008
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
99 f350 rough idle lack of power

i installed the power pup set it to the highest setting of 120 and it didnt do a damn thing no smoke no power nothing took it out and it runs the same rough idle lack of power i was told i am having a fuel problem 65 psi on rails bully dog says fuel filter but i changed it then i was told i have one in the tank can anyone help thanks
99strokeit is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-13-2008, 09:50 PM
Powerstroke.org Rookie
 
Join Date: Nov 2007
Location: medford,OR
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
pull the codes first ...?is your truck a auto or stick ive heard of computer throwing fitts be cause performance chip is trying to change shift schule in a manual gearbox or vise versa!
mechanic@ivfire.com is offline  
post #3 of 6 Old 02-14-2008, 03:30 AM Thread Starter
Powerstroke.org Rookie
 
99strokeit's Avatar
 
Join Date: Feb 2008
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
its a auto trans and i have no codes i hooked it up to the snap-on modis and did every test and still nothing
99strokeit is offline  
post #4 of 6 Old 02-14-2008, 10:03 PM
Powerstroke.org Rookie
 
Join Date: Nov 2007
Location: medford,OR
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
OK did this truck run funny before you installed the chip?cause if not it could be the chip
But i dont know the bully dog line of products at all i hav a super chip and have never had one problem out of the one i put in my truck.. I have had problems with one on another 7.3 but that is another story
mechanic@ivfire.com is offline  
post #5 of 6 Old 02-14-2008, 10:12 PM
Powerstroke.org Rookie
 
Join Date: Nov 2007
Location: medford,OR
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
you could have a fuel sucking air problem ...on 7.3 there could be a hundred things that will cause this problem First i would check the fuel lines under the left head for o ring damage leakage then i would checkthe lift pump for leaking but i dont own a 99 mines a 02 and i work on 95-97s all day every day
mechanic@ivfire.com is offline  
post #6 of 6 Old 02-15-2008, 09:23 AM Thread Starter
Powerstroke.org Rookie
 
99strokeit's Avatar
 
Join Date: Feb 2008
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes it had a weird idle before im gonna try to drop the tank and see if the strainer is clogged who knows i only had this truck a month now and hoping to figure all the bugs out
99strokeit is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome