High idle, stays a about 1k rpms - Ford Powerstroke Diesel Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 04-12-2013, 01:38 PM Thread Starter
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
High idle, stays a about 1k rpms

Had truck worked on and they reflashed it now the truck wont idle down. It is staying up around 1k rpms. When it put it in park it seems to idle down one time but not the next to about 6-700. Any idea's?

2000 F350 2x4 superduty Dualy
5" drop
24" alcoaa rims w/ grappler uhp's
4" turbo back ex.
edge programmer
K&N intake with Napa 6637 filter
06' Grill, Mirriors, Led lights
444kyle is offline  
post #2 of 18 Old 04-12-2013, 03:25 PM
Powerstroke.org Fanatic
 
Jakeman711's Avatar
 
Join Date: Mar 2013
Posts: 139
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The EOT sensor is one of the sensors that the PCM uses to tell if the truck needs to be at high idle. I have seen a bad EOT sensor cause this. This is only when the truck is in park though, auto trans of course.

[SIGPIC]

99.5 F-250 4x4, 7.3 PS
Engine:
State 1 injectors from Rosewood, GT38 (van) turbo, S&B intake, Comp Cam's 910 valve springs, Smith Brothers pushrods, AIH delete TS 6-position chip. Pyro.

Body:
2005 front end conversion, 2008 tailgate, taillights, and rear bumper.

Future Mods:
Edge CTS monitor, and 4" Exhaust (Manufacturer to be determined).
Jakeman711 is offline  
post #3 of 18 Old 04-13-2013, 04:30 AM Thread Starter
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I will check. but mine does do it more often when in drive not park.

2000 F350 2x4 superduty Dualy
5" drop
24" alcoaa rims w/ grappler uhp's
4" turbo back ex.
edge programmer
K&N intake with Napa 6637 filter
06' Grill, Mirriors, Led lights
444kyle is offline  
post #4 of 18 Old 04-13-2013, 04:37 AM Thread Starter
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
also truck has been lobing at idle. noticed my friends did it but only when it was help wide open which caused the injectors to starve for fuel when he lets off. then after a few seconds it goes back to normal. mine will sit there and lobe the same way for ten min.

2000 F350 2x4 superduty Dualy
5" drop
24" alcoaa rims w/ grappler uhp's
4" turbo back ex.
edge programmer
K&N intake with Napa 6637 filter
06' Grill, Mirriors, Led lights
444kyle is offline  
post #5 of 18 Old 04-13-2013, 01:20 PM
Powerstroke.org Fanatic
 
Jakeman711's Avatar
 
Join Date: Mar 2013
Posts: 139
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Does the truck have a miss at all?

[SIGPIC]

99.5 F-250 4x4, 7.3 PS
Engine:
State 1 injectors from Rosewood, GT38 (van) turbo, S&B intake, Comp Cam's 910 valve springs, Smith Brothers pushrods, AIH delete TS 6-position chip. Pyro.

Body:
2005 front end conversion, 2008 tailgate, taillights, and rear bumper.

Future Mods:
Edge CTS monitor, and 4" Exhaust (Manufacturer to be determined).
Jakeman711 is offline  
post #6 of 18 Old 04-13-2013, 04:52 PM Thread Starter
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes it is missing and stumbling at idle

2000 F350 2x4 superduty Dualy
5" drop
24" alcoaa rims w/ grappler uhp's
4" turbo back ex.
edge programmer
K&N intake with Napa 6637 filter
06' Grill, Mirriors, Led lights
444kyle is offline  
post #7 of 18 Old 04-14-2013, 11:14 PM
Powerstroke.org Rookie
 
Join Date: Dec 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check you ICP sensor for oil in the connector. Try unplugging it and see if the problem goes away. If it does the ICP is bad. If there is oil in the connector replace the sensor.

2001 F250 SC/LB
Afe stage1, 4" MBRP 409 SS turbo back,DP F5 Tuner,
Isspro EV guages, Wicked Wheel
Glassdude is offline  
post #8 of 18 Old 04-18-2013, 05:00 AM Thread Starter
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
new icp and checked wires. its weird because its hanging at about 950-1100 when you come to a stop in gear. then when you shift to park it drops to about 800. which is still alittle high I think.

2000 F350 2x4 superduty Dualy
5" drop
24" alcoaa rims w/ grappler uhp's
4" turbo back ex.
edge programmer
K&N intake with Napa 6637 filter
06' Grill, Mirriors, Led lights
444kyle is offline  
post #9 of 18 Old 08-28-2013, 03:38 PM
Powerstroke.org Rookie
 
73Z28CAM's Avatar
 
Join Date: Nov 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
High idle, stays a about 1k rpms

did you ever get this resolved??
73Z28CAM is offline  
post #10 of 18 Old 08-29-2013, 06:43 AM Thread Starter
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
no I sold it got tired of dealing with it. went back to a truck I trust. Bought a new tundra.

2000 F350 2x4 superduty Dualy
5" drop
24" alcoaa rims w/ grappler uhp's
4" turbo back ex.
edge programmer
K&N intake with Napa 6637 filter
06' Grill, Mirriors, Led lights
444kyle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome