95 Turbo Intercooler dies at stops - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-08-2008, 06:01 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
95 Turbo Intercooler dies at stops

95 Turbo Intercooler,Auto,Exhaust Brake....Inttermitely dies at stops. Does not seem to matter if its cold or hot. Starts right back up. Inducater lights are on after it dies,battery light and so on. After it died last time it set a DTC of P0475-Exhust Back Pressure Control Valve. Would sure like some HELP with this problem. I am new to the diesel world. Thank you
wheelindude is offline  
post #2 of 4 Old 02-08-2008, 06:04 AM
Powerstroke Techie

 
djsdiesel's Avatar
 
Join Date: Nov 2006
Location: Moses Lake, WA
Posts: 723
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
sounds like a cam sensor. Have the codes checked if it has P0340, p0341, p0344 it most likely a cam sensor.

99.5 F-250 PSD AT 4x4, 4in lift, 37 13.5 18 Pro comp Extreme A/T's, S&B Intake, GTP38R, DP Tuner custom programs (140 Agg., 120 sled pull, 80 tow and 60 tow), Rosewood DIY stage 2 injectors, BTS Trans, 5in exhaust no muffler, 6 oh intercooler, Ford AIC, EBPV delete, Foil delete, T/C lock up mod, Pusher Fuel Pump, Three Chime train Horns

djsdiesel is offline  
post #3 of 4 Old 02-08-2008, 07:32 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the reply, there are no other dtc's in the system
wheelindude is offline  
post #4 of 4 Old 02-09-2008, 04:54 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
This is my dads truck,ran the vin# on the Ford web site. Found out it is a 99 not a 95. Found that there is a recall on the cam sensors for 99-02 7.3. Had them done yesterday and the seems to be runing fine so far. Thanks for the help.
wheelindude is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome