boost ? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-05-2008, 05:51 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
boost ?

ive got a 2000 f250 and it has the banks powerpack in it. my question is, is it normal for it to not have any boost until about 2000 rpm?
thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-06-2008, 11:08 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
does anybody have an idea?
Reply With Quote Quick reply to this message
  #3  
Old 02-18-2008, 08:21 AM
Powerstroke.org Rookie
 

Join Date: Feb 2008
Location: houma
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
wastegate valve. jiggle the lever and see if it fits loosely if it is the waste gate or turbine housing is bad buy your self time by adjusting the actuator rod. i am having the same problem but mine is beyond help.
Reply With Quote Quick reply to this message
  #4  
Old 02-18-2008, 08:38 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Hondo Tx
Posts: 206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what exact levels do you mean 1-5 psi or just 0
Reply With Quote Quick reply to this message
  #5  
Old 02-19-2008, 06:22 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok ill take alook at that and yeah it just says 0
Reply With Quote Quick reply to this message
  #6  
Old 02-19-2008, 06:33 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: frazeysburg ohio
Posts: 803
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
its also quite possible your gauge is just wrong
Reply With Quote Quick reply to this message
  #7  
Old 02-19-2008, 06:51 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Georgetown, TEXAS
Posts: 771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by todd View Post
its also quite possible your gauge is just wrong
It's happened to me... a bad gauge.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:02 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors