Installed WW gen2. Now I have no power at all. Help! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-06-2013, 06:05 PM Thread Starter
Premium Member
 
Join Date: Sep 2012
Location: WNY
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Installed WW gen2. Now I have no power at all. Help!

Ok so by no power I mean. The truck barley gets moving. I don't mean a electrical problem. Ok so here's the story. I bought a ww2 and a 4in dp. Pulled the turbo installed wheel. Put dp and stacks on. Also did ccv mod and unhooked ebpv and Wastegate. So as soon as I drove the truck I noticed in economy settings the truck struggled to get going and only got like 7psi. Same in all settings except extreme. Before. Huge clouds of black smoke and it moved pretty good. Now little black smoke. But moves about the same. Egt sky rocket tho. Almost as fast as tach. Getting around 25psi. 3 days after install sensor broke on my isspro Boston gauge. Still didn't replace it. I took a trip the last few days through the hills of PA. In all settings expect extreme. I would be at wot up hills and being passed by tractor tailers. The truck has no power now what so ever. Even in extreme. It struggles a little up hills. Also noticed a few days after all installs a small oil leak from middle front of motor. A quarter sized drop a day roughly. So what could be my problem? Tuner? Am I not getting enough fuel. To much air? What should I test/check? Thanks.

Sent from my VS930 4G using AutoGuide.Com Free App

01 F350 dually CCLB Lifted 7in
WW Gen2
6637 w/zoodad
6pos tuner canned tunes
isspro ev2 pyro, boost, trans temp
4.5" custom stack
AIH delete
CCV mod
22.5 rims on there way
ventryjr is offline  
post #2 of 5 Old 04-06-2013, 11:05 PM
Serving Our Country!
 
JSchuricht's Avatar
 
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,972
Thanks: 0
Thanked 25 Times in 24 Posts
Mentioned: 1 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
You probably have a leak. Check all the boots, up pipes and the oring between teh turbo and spyder.

JSchuricht is offline  
post #3 of 5 Old 04-07-2013, 07:02 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
why would you even consider, to still driving it, if that much had happened after trubo replacement...

Check the turbo to collector. If the "pin" isnt aligned, you'll have no power.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #4 of 5 Old 04-07-2013, 11:57 AM Thread Starter
Premium Member
 
Join Date: Sep 2012
Location: WNY
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I continued to drive it because I had to for work. And I thought it was a tuner issue. Also can you give a better description of this pin? And what exactly is the collector? Sorry I'm not overly familiar with turbos

Sent from my VS930 4G using AutoGuide.Com Free App

01 F350 dually CCLB Lifted 7in
WW Gen2
6637 w/zoodad
6pos tuner canned tunes
isspro ev2 pyro, boost, trans temp
4.5" custom stack
AIH delete
CCV mod
22.5 rims on there way
ventryjr is offline  
post #5 of 5 Old 04-07-2013, 05:30 PM Thread Starter
Premium Member
 
Join Date: Sep 2012
Location: WNY
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Found the problem. Forgot to hook map sensor back up. Simple fix. Only took me like 45 mins to notice. And anyone know where to find sensor for isspro ev2 boost gauge?

Sent from my VS930 4G using AutoGuide.Com Free App

01 F350 dually CCLB Lifted 7in
WW Gen2
6637 w/zoodad
6pos tuner canned tunes
isspro ev2 pyro, boost, trans temp
4.5" custom stack
AIH delete
CCV mod
22.5 rims on there way
ventryjr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome