Injection Pressure Drop 3-400psi For Split Second - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-04-2013, 05:34 PM Thread Starter Rookie
BiodieseLizard's Avatar
Join Date: May 2010
Location: Upstate SC
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injection Pressure Drop 3-400psi For Split Second

Noticed my 2000 7.3 "bucking" several months back. Changed the oil, installed a new International CPS, Swapped IPR and it seemed to go away. Thought I had the problem gone but it came back even worse several weeks ago. The truck feels like it is about to cut off for a split second and then picks right back up. Was watching injection pressures going down the road with it doing what it does and noticed that the scanner picks up a 3-400psi pressure drop when the truck "bucks." My scanner refresh rate is barely fast enough to pick up the drop, so that is how fast it drops then regains. This happens while maintaining highway speed and injection pressures of 16-1800psi. Any ideas on where to go next? Figured if all else fails I will be putting a T500 in but I'd rather not spend that money right now.

'86 RCLB 2WD 6.9L T19
BiodieseLizard is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome