Tic, tic? Fuel related? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 03-31-2013, 07:14 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tic, tic? Fuel related?

Is it possible I have a fuel related issue that is making a weird ticking noise , sort of like a noisy lifter that come and goes? Steady state and there is no tick, ask for some fuel when the truck is cold and not fully warmed up and you get a ticking sound. (sort of like the motor was low on oil.) The challenge is that if I stop the truck and open the hood its GONE. It is RPM related.
jester4always is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 03-31-2013, 08:21 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
its the "cackle" these motors are known for. You can help it out by doing the hutch mod and installing a FRx or regulated return.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 10 Old 03-31-2013, 09:16 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nope, that's not it, its a real ping. Like a poppet valve, or a bent push rod, except this doesn't always do it, mostly when cold. Almost like she is starving for fuel and starts to die out, then catches back up.
jester4always is offline  
post #4 of 10 Old 03-31-2013, 09:19 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
bent rod, you'd hear thatt thru the exhaust or intake/filter. The hutch and reg return / frx IS fuel related itmes to do/upgrade.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #5 of 10 Old 03-31-2013, 09:25 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Push rods are O.K, I have checked those, I have a Hutch mod done, I have the Campgound mode on my flip chip...This is almost a ratchet slipping noise in time with the RPM, doesn't always do it. Some days it is fine. Til I call for power
jester4always is offline  
post #6 of 10 Old 03-31-2013, 01:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is it possible I have a Fuel pressure regulator issue?
jester4always is offline  
post #7 of 10 Old 03-31-2013, 01:59 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
It's possibly you have a lot of different issues.
From bad CPS and perdel readings, to fuel pressure, air in fuel, high pressure oil delivery issues, injector issue, push rod issue, and many others.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #8 of 10 Old 03-31-2013, 02:27 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
AE says my Perdels look good, the only code is a long standing IDM code that has been floating round forever. Replaced both Valve cover gaskets and harness last week due to a code showing a Injector fault with #5 that cleared up with the new UVCH , checked all push rods ( yup pain in the butt although worth the peace of mind.) Running AE while going down the road I see no missfires when monitoring each cyl while this ping happens, although I sense a lack of power of sorts. I have swapped out CPS, Grey and Black, no difference. Fuel pick up modified last year in a "extreme" hutch mod that I have done to other trucks. Fuel filter replaced, although I must admit I just realized I might want to check the screen between bowl and FPR. Its the Damn Ticking noise that has me, I think I am going to install a gauge on the fuel system this week and see what is going on there. I am more and more suspecting sticking FPR....
jester4always is offline  
post #9 of 10 Old 01-31-2014, 08:53 AM
Powerstroke.org Rookie
 
Ryans71's Avatar
 
Join Date: Jan 2006
Location: Milton, Wa
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you figure out what the issue was/is? I have a similar tick on acceleration/high load. But not at low RPM.

'02 F350 Dually Crewcab 4x4, PSD, Auto, Lariat, Longbed, 4" exhaust, AIS intake

'71 Bronco, 302EFI, D44 & 9" w/ARBs, 4.27's, alloy shafts, CTMs, 37" MTRs, onboard air, 8274, 4 wheel disks, 4" lift w/ Extended Arms

'04 Arctic Fox 990 Camper
Ryans71 is offline  
post #10 of 10 Old 02-01-2014, 08:29 PM
Member
 
harness00's Avatar
 
Join Date: Jun 2011
Location: coatesville IN
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what kind of fuel filter are you running

harness00 2000 ford f-250 7.3 psd swamps hybrid 250/100% injectors, swamps high frequency idm, custom ts chip, garrett gtp38r turbo, k&n intake, banks techni cooler, hpx cross over line, fuel lab prodigy fuel pump, south bend ceramic button clutch, adrenaline hpop, driven regulated return, swamps high rate valve springs, smith brothers billet pushrods, 4in down pipe 5in exhaust, 5" miter cut black stack, soon to be 7" hood stack probably.
harness00 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome