stock 03 psd rough running - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-28-2013, 10:20 AM Thread Starter Rookie
Join Date: Mar 2013
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
engine light on and off ???

I've got an '03 all stock psd that is running rough, sometimes, hard starter and engine light comes on and off while driving. light seems to go off and truck runs smoother when I ease into it, but if I get on it a little, light comes back on and blows black smoke. Uses a little oil but not too bad. Also noticed some oil inside air intake tube where crank case vent is plumbed in. Figured vent is dirty and thus not creating enough vacum. Could this be causing it to blow smoke when I get on it?

Last edited by abogle; 04-02-2013 at 02:50 PM.
abogle is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome