fresh overhaul with lots of goodies...now low oil pressure - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2013, 08:16 PM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: Grant, Nebraska
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fresh overhaul with lots of goodies...now low oil pressure

alright experts i need your help.

just did a fresh overhaul on my 99 f350. new pistons, rings, t500 hpop, 238/80 hybrids from unlimited, s468 turbo from carson stauffer, new melling lpop, h11 studs, 910 springs, smith bros push tubes, lifters, fluidampr, tunes from gearhead, milled the decks .010 to make them flat, new valve guides and seats, etc...

i got her running and was very happy, until i was breaking it in and looked down after everything was good and warm and the oil pressure guage was on 0 and the oil temp light was on. i panicked and shut it down to survey the situation. no oil leaks, oil level was right were it should be, hpop reservoir was full and everything seemed normal.

so i braved it and started it to drive it back to the shop, hoping maybe it was a faulty sensor or something. once i started to drive it the pressure came back up. however, as soon as i let it go back to idle the guage would drop to 0 again. it doesn't take more than 100 rpms off idle to make it come back up.

i put the computer on it and i get a p1280 icp code. run a contribition test and it gives me codes for cylinders 3 and 8. i don't understand how any of these can be related to the oil pressure.

i've checked the bypass valve in the oil filter housing, pulled the valve covers to check for a broken rocker arm, but everything looks normal.

anyone have any ideas? it seems to run fine, will make 33 lbs of boost on the heavy tow (mildest) setting. i dropped the oil and was going to look through the drain plug hole with a snake camera, but my camera wont fit through the hole.

i'm a bit lost at this point...

thanks in advance.
max
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-21-2013, 09:37 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Posts: 1,854
Thanks: 0
Thanked 18 Times in 18 Posts
Feedback Score: 0 reviews
did some searching ,and most of the remedy, has been this...

7.3 Low Oil Pressure
Reply With Quote Quick reply to this message
  #3  
Old 03-22-2013, 07:55 AM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: Grant, Nebraska
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the tip. i will look into that this evening. i guess i didn't realize there was another valve in there somewhere.

hopefully that is what it is.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:55 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors