battery terminal problem. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-20-2008, 06:09 PM
Serving Our Country!
 

Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
battery terminal problem.

Just a question I have to clean my battery terminals just about every three days to get my truck to start. There not dirty they just have like a glaze on them there like a dull gray not shiny like they are when i clean them. what could the problem be is it weather related thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2008, 07:01 PM
Serving Our Country!
 

Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump please
Reply With Quote Quick reply to this message
  #3  
Old 01-20-2008, 07:02 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Bellevue, Nebraska
Posts: 526
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same problem here, what kind of batts do you have?
Reply With Quote Quick reply to this message
  #4  
Old 01-20-2008, 07:05 PM
Serving Our Country!
 

Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
everstart they worked fine in the summer
Reply With Quote Quick reply to this message
  #5  
Old 01-20-2008, 07:07 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Bellevue, Nebraska
Posts: 526
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i've got bosch and also no prob in the summer
Reply With Quote Quick reply to this message
  #6  
Old 01-20-2008, 07:12 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It may because of some thing that pulls power from it all the time mb like a phone charger are some hard wired to the batterys
Reply With Quote Quick reply to this message
  #7  
Old 01-20-2008, 07:14 PM
Serving Our Country!
 

Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Iv got nothing that would be pulling from the battery

Last edited by sawyer1; 01-20-2008 at 07:19 PM.
Reply With Quote Quick reply to this message
  #8  
Old 01-20-2008, 07:18 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Bellevue, Nebraska
Posts: 526
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same here.
Reply With Quote Quick reply to this message
  #9  
Old 01-20-2008, 07:33 PM
Serving Our Country!
 

Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone know what to do?
Reply With Quote Quick reply to this message
  #10  
Old 01-20-2008, 07:33 PM
allergic to hot weather

 

Join Date: Nov 2007
Location: Anchor Point, AK
Posts: 1,208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 95and05 Send a message via MSN to 95and05
are the cables corroded at all (cables to end connectors) and also check connections at other end of cables (starter and frame/block)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors