HELP ME PLEASE! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-20-2008, 01:45 PM
Member
 

Join Date: Nov 2007
Location: Cedar Park
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP ME PLEASE!

ok yall, on my way home from San Antonio my truck was running fantastic, Got to the mid point between there and my house, turned the truck off, it sat for 25-30 minutes. Go to start it up and it is super hard to start. Get it started and it idles real irradically (but only about 600 RPM) but ROUGH! Go to put it into drive and barely runs. Can only get it to about 65 mph and it is hell to get it there (About 4 Minutes on flat ground). If I hit just the slightest incline the speed drops like crazy. So.....NO POWER, but No smoke either. Feels like either air in the lines ot a bad fuel filter. Replaced the Fuel Filter, same problem. WHAT CAN IT BE? Please help ME!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2008, 01:46 PM
Member
 

Join Date: Nov 2007
Location: Cedar Park
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oh yeah.....drove the truck about 70 miles like that. Just thought that that is important info
Reply With Quote Quick reply to this message
  #3  
Old 01-20-2008, 01:56 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
any codes???

first thing i would be checking would be valve cover connections and oil level....then fuel pressure...
Reply With Quote Quick reply to this message
  #4  
Old 01-20-2008, 01:57 PM
Member
 

Join Date: Nov 2007
Location: Cedar Park
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no codes, Oil level is on the money, and tons of fuel pressure
Reply With Quote Quick reply to this message
  #5  
Old 01-20-2008, 01:58 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by slow96stroke View Post
no codes, Oil level is on the money, and tons of fuel pressure
check teh connections at the valve covers...if they arent burnt on the outside connectors...check the inside ones......also could be an injector problem...
Reply With Quote Quick reply to this message
  #6  
Old 01-20-2008, 01:59 PM
Member
 

Join Date: Nov 2007
Location: Cedar Park
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah...thats what I am afraid of. ANYONE WANNA BUY IT CHEAP?
Reply With Quote Quick reply to this message
  #7  
Old 01-20-2008, 09:35 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Shreveport, LA
Posts: 214
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same boat here my buddy just got a goat kinda like it but the blue oval pulled its weight more than once when a goat couldnt. lol
Reply With Quote Quick reply to this message
  #8  
Old 01-21-2008, 07:50 AM
Premium Member
 

Join Date: May 2007
Location: Effort/Nanticoke,Pa.
Posts: 5,441
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any updates on your problem yet slow96??
Reply With Quote Quick reply to this message
  #9  
Old 01-21-2008, 07:25 PM
Member
 

Join Date: Feb 2007
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey mark, Hillary doesn't suck. Remember the whole Monica thing? No political trouble wanted. Just a funny joke. Cheers.
Reply With Quote Quick reply to this message
  #10  
Old 01-21-2008, 07:27 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by henrymiller1 View Post
Hey mark, Hillary doesn't suck. Remember the whole Monica thing? No political trouble wanted. Just a funny joke. Cheers.
LMAO....thats great dude...

my impression though is monica blows...and hillary still sucks!!! LOL (again all in good fun!!)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors