2000 7.3 Rough Idle Low Power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2013, 11:50 AM
Member
 

Join Date: Jul 2010
Posts: 30
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 7.3 Rough Idle Low Power

I will attempt to be as descriptive as I can since I have searched and come up empty handed so far. This problem was intermittent until yesterday and now it is a steady problem. The engine seems to have a miss in it, it idles rough and when i press the accelerator the miss becomes more pronounced. You can hear it through the exhaust and also at the engine and the engine rocks more than it should. The other day when i was coming home from work it started and seemed to be in and out for example i was going up a hill and it would be running rough, low on power then all the sudden it would be fine all the power would be back and i would be hauling *** but then as soon as the problem went away it was back again. There is no SES light on and i have changed my oil very recently and i changed my fuel filter this morning. Any help is appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-14-2013, 04:54 PM
WNY Biodiesel Co-op
 

Join Date: Mar 2008
Location: Orchard Park New York
Posts: 868
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Check the tin nut on the back of the IPR, make sure its tight. Check the ICP for oil in the connector. Have you changed out the CPS? Possible loose connection on the UVCH check out this mod 50 cent mod - Ford Truck Enthusiasts Forums


PLEASE HELP!! E99 runs really rough!!
Reply With Quote Quick reply to this message
  #3  
Old 03-14-2013, 09:45 PM
Compression Ignition Addict
 

Join Date: May 2012
Location: Port Coquitlam, BC
Posts: 189
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I had a similar issue. I changed IPR, ICP and CPS together. No more problems.
Reply With Quote Quick reply to this message
  #4  
Old 04-08-2013, 11:09 AM
Member
 

Join Date: Jul 2010
Posts: 30
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok ill check all that. I haven't done the 50 cent mod. I've been in the field for a few weeks so I haven't had time to work on it. Thanks for the help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:32 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors