New Owner - Won't Start - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-16-2008, 06:16 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2008
Location: Athens TN
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
New Owner - Won't Start

Hello all, I purchased a 95 7.3 about two weeks ago, and love it, however two days ago I went out to start it for work, and it won't turn over, I thought it was to cold, so I plugged it in that night, but the same the next day. Electrical Power seems OK, it has fuel, I have never run it out, the wait to start light comes on for 5 to 10 seconds then goes out, and it clicks, but nothing else. Where should I start troubleshooting from. Thanks everyone.
dcpcook is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-16-2008, 06:33 AM
Premium Member
 
smuesse's Avatar
 
Join Date: Sep 2007
Location: Hubbard, Texas
Posts: 1,117
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Sounds like a starter or Solinoid but i would start with checking your wire connections.

Scott Muesse
Hubbard Texas (Near Waco)
1999 F-350 7.3 4x4 CCLB
2015 Palomino Puma 30-RKSS
'73 F-100 Restoration Project
'05 ClubCar gas golf cart
smuesse is offline  
post #3 of 5 Old 01-16-2008, 02:50 PM
525
Member
 
Join Date: Nov 2007
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had the same problem last year. It would click but not turn over. I knew the batteries were new. I followed the large power cable down to the starter and there it was, rusted as all h---. two electrical connections face forward and pick up all the grud from the road. I cleaned up all the connections put some dilalectic (sp) grease on it and gave it another coating of bearing grease. It's been fine since. Might be something others might want to check as a PM point....
525 is offline  
post #4 of 5 Old 01-16-2008, 04:26 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2008
Location: Athens TN
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Biingo

You were both correct, I got home from work today, pulled the battery cables and cleaned, still did not work, I pulled the main cable off the starter, cleaned it up, and put it back on, started right up. Thanks for the help.
dcpcook is offline  
post #5 of 5 Old 01-16-2008, 05:36 PM
525
Member
 
Join Date: Nov 2007
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Chef,,,glad to hear it worked for you.....525
525 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome