low oil pressure please help - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-12-2013, 09:56 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
low oil pressure please help

hello i have a 1999 f350 7.3l with ts 6 position chip it has 245,000 miles recently started running and idleing really rough noticed the oil pressure gauge shows 0 we have replaced the ipr valve and the icp no help smoothes out at higher rpm hard starting and shakes whats next to check and info would be great also changed oil because there was fuel in it but no help either
dohertypropertymaint is offline  
post #2 of 6 Old 03-12-2013, 10:59 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
if you got fuel in your oil, you need to check orings on injectors. Might as well, buy thee entire kit to replace all the orings.

Going on a limb here, but if oring/s are bad, then i can see how the lpop cant create pressure..(low oil pressure), with a shot oring, or the lpop itself is just bad too. Melling 208 is what they replace them with....but fuel in oil, you need to find the culprit.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 6 Old 03-12-2013, 11:33 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Do I need any special tools to remove injectors and is there a way to tell which one may be bad before I pull them
dohertypropertymaint is offline  
post #4 of 6 Old 03-12-2013, 08:51 PM
Powerstroke Techie
 
Join Date: Apr 2012
Posts: 2,180
Thanks: 43
Thanked 83 Times in 83 Posts
Mentioned: 41 Post(s)
Quoted: 104 Post(s)
Feedback Score: 0 reviews
if the truck is running and your oil pressure gauge is not registering, the gauge is inaccurate. either due to the sender, gauge, or wiring.
check your codes and report back

the richest ones are not those who have the most, but those who need the least
kaya is offline  
post #5 of 6 Old 03-13-2013, 04:39 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes I figured the gauge is ring because if there was truly no oil pressure then the truck would. Not run but still runs very rough but no blue or white smoke
dohertypropertymaint is offline  
post #6 of 6 Old 03-13-2013, 07:35 PM
Powerstroke Techie
 
Join Date: Apr 2012
Posts: 2,180
Thanks: 43
Thanked 83 Times in 83 Posts
Mentioned: 41 Post(s)
Quoted: 104 Post(s)
Feedback Score: 0 reviews
have you checked for codes?

the richest ones are not those who have the most, but those who need the least
kaya is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome