Coolant Smell - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2008, 07:29 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Motor City
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Coolant Smell

I am for the most part mechanically inclined, to an extant. I just bought this 2001 7.3L last month with 100k on it. With no maintenance history or anything. It is my first 7.3L I had a 6.0L for a short period of time(a lot of issues) I am smelling a light coolant smell coming from my engine and threw my vents with the heat on. Coolant level is fine, no visible leaks. Any ideas on why I am getting the smell? No white smoke out the exhaust so a head gasket leak is out of the question, I assume? Any help? Thanks! Anything to look for??????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-07-2008, 07:43 PM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,088
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
look under the front of the truck. See if any coolant is on the ground. Check the tierods and draglink for coolant drips. Also check the bottom of the motor.

The water pump is very common to go out on these trucks and will drip occasionally and then gush and leave you stranded.
Reply With Quote Quick reply to this message
  #3  
Old 01-08-2008, 07:33 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Motor City
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thank you!!!!
Reply With Quote Quick reply to this message
  #4  
Old 01-08-2008, 07:36 PM
Member
 

Join Date: Oct 2007
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The coolant smell inside coming from the vents also would lead to a possible heater core starting to leak
Reply With Quote Quick reply to this message
  #5  
Old 01-08-2008, 07:42 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Location: SE PA
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem on a 01 550 except I dont smell it inside. New water pump 20k ago, no leaks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors