Died mid drive - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2008, 05:15 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Shamong, NJ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to EdBoy9573
Died mid drive

My 7.3 died on me driving down the road the other day and had to be towed home. The first thought in my head was CPS. Fiddling around with it today though I noticed my glow plugs dont turn on at all and my overdrive is turned off when I turn on my key. I hooked up my Superchips scanner and it is getting a "No Response" when I try to read the DTC's. I'm hoping my PCM isn't fried!!! What do you guys think?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-06-2008, 05:18 PM
Banned
 

Join Date: Jun 2007
Location: Denver Co.
Posts: 1,684
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Almost sounds like a PCM to me...
Reply With Quote Quick reply to this message
  #3  
Old 01-06-2008, 05:21 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,241
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
have you checked all fuses
Reply With Quote Quick reply to this message
  #4  
Old 01-06-2008, 05:31 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Shamong, NJ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to EdBoy9573
no i havent. I can check them in the mornin if u think thats a good idea.
Reply With Quote Quick reply to this message
  #5  
Old 01-06-2008, 05:50 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Shamong, NJ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to EdBoy9573
Just checked em. Both in-cab and junction box fuses are good.
Reply With Quote Quick reply to this message
  #6  
Old 01-06-2008, 05:52 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,241
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
and you said you have no wait to start light
Reply With Quote Quick reply to this message
  #7  
Old 01-06-2008, 05:57 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Shamong, NJ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to EdBoy9573
nope. doesnt even flicker. i tried puttin the jumpbox on incase its a battery thing and that didnt make a difference. it wont run on ether either.
Reply With Quote Quick reply to this message
  #8  
Old 01-06-2008, 06:02 PM
Member
 

Join Date: Jul 2007
Location: Albuquerque
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dude! I would recommend the CPS from International and see waht that does. If not I would swap a few relay's in the cab and see what that gives you. SOmetimes with our older 7.3s it has worked with the relay swap. I recently bought the CPS thru dfuser.com that is made by International ( makers of our engine) and the gains are so much better tahn the 28.00 dollar Ford Part. Hope you get it figured out and please post what the fix was for us 7.3 guys
Reply With Quote Quick reply to this message
  #9  
Old 01-06-2008, 06:29 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Shamong, NJ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to EdBoy9573
Will do. I have a friend with a wreaked 7.3 im gonna get the PCM and CPS off of and see what comes out of it. Ill post back when I try that hopefully can get on it tomorrow.
Reply With Quote Quick reply to this message
  #10  
Old 01-07-2008, 06:38 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Shamong, NJ
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to EdBoy9573
Welp got my hands on the spare pcm.... not the cps tho... but swapping the pcm didnt make a bit of difference so im bettin its that dang cps!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors