HELP no throttle(power) after deceleration !! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-03-2008, 02:48 PM
Member
 

Join Date: Jul 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP no throttle(power) after deceleration !!

This is weird the check engine light comes on and the truck will not accelerate , it only happens after letting of of the gas pedal ( when decelerating) !!

Then the light goes off and the truck acts fine ?? And then it does it again ?
I scanned it and it has no check engine light ? 99 7.3 powerstrock Automatic.. 2wheel drive truck has 200k miles

Last edited by Davepnola; 01-03-2008 at 04:28 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-03-2008, 02:57 PM
BIG TRUCK, SMALL DRIVER
 

Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is it cold when it does it? The EBPV may be sticking. Mine acts wierd sometimes and does what you describe. The EBPV act normal for a few minutes, then goes crazy and stays on even when trying to accelerate. Do you hear a hissing sound coming fromunder the hood?

Btw: I moved this to a place that will get better attention for you.
Reply With Quote Quick reply to this message
  #3  
Old 01-03-2008, 03:00 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: murfreesboro TN.
Posts: 885
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
not sure where i saw the ford TSB but it pertained to no power after hard accel and then return to coast. if i find it I'll forward it to ya, meanwhile look in the tech section of this site and also superdutydiesel.com or just google "ford technical service bulletins"
Reply With Quote Quick reply to this message
  #4  
Old 01-03-2008, 03:12 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: murfreesboro TN.
Posts: 885
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
tried to link the TSB, no luck. the number is 04-24-11. and the new accel pedal part # 1C3Z-9F836-BA. hope that helps
Reply With Quote Quick reply to this message
  #5  
Old 01-03-2008, 04:16 PM
Member
 

Join Date: Jul 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No mine makes no funny noises or hisses . It just acts like that ihas no throttle response, but idles fine and the check engine light comes on. I scanned it does not have any code ? Could CPS do this , I read sometine CPS causes timing caurelation problem and returns then engine to idle ?? Is that true ? I have and edge power programmer on another truck I can pull it see if it will show the will the problem occurs. Does the edge show ignition advance ?? Thanks Also does this truck have a throttle cable ? What is the switch under the gas pedal ??
Reply With Quote Quick reply to this message
  #6  
Old 01-03-2008, 04:43 PM
Member
 

Join Date: Jul 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My truck is 99 the TSB says 2001-2003 , but this is exactly what is happing to the truck besides no code P0123 ? I thought this truck is drive by wire ( no throttle cable) If that is the case my first response was this switch under the gas pedal . Thanks
Reply With Quote Quick reply to this message
  #7  
Old 01-03-2008, 04:46 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yep its called the tps or throttle position sensor.
Reply With Quote Quick reply to this message
  #8  
Old 01-03-2008, 04:50 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Here is a link to buy the sensor. If you try to buy from ford you have to buy the whole pedal assembly.http://www.dormanproducts.com/docume...s_Sensors2.pdf
Reply With Quote Quick reply to this message
  #9  
Old 01-03-2008, 05:02 PM
Member
 

Join Date: Jul 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks I will try that , I thought that was the problem, because I can pedel the pedal fast it would catch sometimes.
Reply With Quote Quick reply to this message
  #10  
Old 01-03-2008, 05:04 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yeah not sure if thats it kinda sounds like it is, but at least you know where to get the sensor cheap
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors