Running Rough - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-02-2008, 05:33 PM
Member
 

Join Date: Dec 2007
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Running Rough

Just changed out the Glow Plug Relay.. then added 8 new glow plugs.. installed them correctly, and buttoned it up right. Started up good, but runs like crap and the check engine light is on??

Anyone have this problem before after doing a glow plug changeout????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-02-2008, 05:35 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
pull the valve covers back off and check the under valve cover harnesses. You either knocked one off an injector, broke a wire, or it isnt seated into the valve cover all the way...
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2008, 05:41 PM
Infidel

 

Join Date: Jun 2006
Location: Texas
Posts: 5,167
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Welcome to the .ORG the guy who posted above me knows what he's talking about.
Craig
Reply With Quote Quick reply to this message
  #4  
Old 01-02-2008, 06:51 PM
Member
 

Join Date: Dec 2007
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks.. I will try that tomorrow.. it got late so I had to quit for the night. Would it be worth getting the codes read?
Reply With Quote Quick reply to this message
  #5  
Old 01-03-2008, 06:02 AM
Infidel

 

Join Date: Jun 2006
Location: Texas
Posts: 5,167
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the valve cover harness first, then get the codes read. Just so you know, the code readers at Autozone and Orielly's don't generally work on our trucks. You have to find someone with a pretty decent code reader to pull the codes. Good luck and keep us posted.
Craig
Reply With Quote Quick reply to this message
  #6  
Old 01-03-2008, 10:20 AM
Member
 

Join Date: Dec 2007
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I hope that it is obvious when looking at the wiring.. When I pulled everything apart and put it back together I was as delicate as possible. Hopefully something just got bumped off and not broken.

I see that there is a UVC wiring harness WEDGE from Ford??? What would that do, and why do they have such a part???
Reply With Quote Quick reply to this message
  #7  
Old 01-03-2008, 01:37 PM
Member
 

Join Date: Dec 2007
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FIXED IT.... Thanks for all your help.. I pulled the pass side valve cover first because when I thought about it... I did have to figit with that side putting it back on. Sure enough.. the harness was unclipped and out almost 1/4 inch. Hopefully she stays together for a bit... I am going to send my truck in for the recall, and inquire about the SERVICE Pack for the harness, that has new clips.

Has anyone had any luck with that service pack???

Thanks for all your help once again...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors