Turbo shot or not? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-01-2008, 04:20 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Columbus
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Turbo shot or not?

Hey guys,

Got a late 99 f350 with 300k with the original turbo stock intake and exhaust. I do have a superchip and just put gauges on for christmas and The most boost I can get out of it is 12 psi and that is hammering the go pedal. I read someone else's post and they said the stock turbo was good for about 25-28 psi, but they had and intake and maybe exhaust. Shouldn't I be getting more than 12? If so, do you think it is the turbo or a wastegate problem.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-02-2008, 04:16 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Columbus
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
After driving more today I'm seeing about 4 # of boost at 2200 rpms under normal driving conditions, If I go up a hill or accelerate it will raise to about 8 and will hit at most 13 will hammering it. Let me know some things to check and how to check them.

Thanks
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2008, 04:19 PM
allergic to hot weather

 

Join Date: Nov 2007
Location: Anchor Point, AK
Posts: 1,208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 95and05 Send a message via MSN to 95and05
i read some other posts here about pluging waste gate tube and increasing boost. i will try to find it and tel you where to look if someone dont beet me to it.
Reply With Quote Quick reply to this message
  #4  
Old 01-02-2008, 04:31 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Columbus
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I want more boost, but I want to make sure That I don't have a problem first, I've tried unplugging the wastegate tube but It didn't run any better, It actually seemed slightly worse.
Reply With Quote Quick reply to this message
  #5  
Old 01-02-2008, 04:33 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Possible boost leak. Are you smoking alot under acceleration? If so check all your intercooler boots and make sure they are tight.
Reply With Quote Quick reply to this message
  #6  
Old 01-02-2008, 04:35 PM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
Is your turbo making any weird sounds?

14psi sounds low, even for a stock program.

Your superchips should have you over 25psi.
Reply With Quote Quick reply to this message
  #7  
Old 01-02-2008, 04:35 PM
allergic to hot weather

 

Join Date: Nov 2007
Location: Anchor Point, AK
Posts: 1,208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 95and05 Send a message via MSN to 95and05
unplug and plug the line is what they were doing they put it on a screw or bolt close by
Reply With Quote Quick reply to this message
  #8  
Old 01-02-2008, 04:38 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yeah I can hit 28 with mine on the performance tune.
Reply With Quote Quick reply to this message
  #9  
Old 01-02-2008, 04:51 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Columbus
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not smoking at all, and the only sound I'm hearing is a sissssssss sound. This morning "when it was 20 degrees outside" my truck was surging for about a mile. It was like i was getting on and off the throttle significantly
Reply With Quote Quick reply to this message
  #10  
Old 01-02-2008, 04:57 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Ah your exhaust back pressure valve is probobly partially stuck closed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors