battery light - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-31-2007, 07:28 PM Thread Starter
Powerstroke.org Fanatic
 
Chrisf97305's Avatar
 
Join Date: Dec 2007
Location: Salem, Oregon
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to Chrisf97305
battery light

Why does my battery light come on when my alt. is putting out 13.8 volts at a idle. That was yesterday, today in the AM it was on again and now it went out and stayed off. What is going on??
Chrisf97305 is offline  
post #2 of 4 Old 12-31-2007, 07:40 PM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Clean all the connections. Clean the battery connections, and alt. connections.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
post #3 of 4 Old 12-31-2007, 08:56 PM
Shaking the Bush Boss
 
CHUCK's Avatar
 
Join Date: Feb 2007
Location: Salisbury, NC
Posts: 9,740
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same intermidant problem. Check the one wire connector on the alternator. Mine works its way loose. I had to put a new connector on the pigtail. It still acts up on occasion.

Chuck
CHUCK is offline  
post #4 of 4 Old 01-01-2008, 06:22 PM
Powerstroke.org Rookie
 
scott3824's Avatar
 
Join Date: Jul 2007
Location: Toledo
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
bump ....

having the same issue ... driving home from atlanta today, alternator is charging fine (at least the voltage gague seems ok). Put 2 brand new optima's in 3 weeks ago.

2000 F250 PSD CC 4x4 XLT
35" ProComp Xtreme AT's on 17" ProComp 6001 rims. Fabtech 3.5" front kit, 1.5" Tuff Country rear add-a-leafs.
Rancho RS5000 shocks
Ford AIS intake.
Infinity Refrence speakers.
Jimmy Jammers.
2007 clear headlights.
Optima Red Tops.

Stuff sitting in the garage until it gets over 30 degrees so I can install it:
MBRP 4" turbo back SS exhaust
Trailer tow mirrors

... and someone in St.Louis has my DVD player
scott3824 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome