7.3 No power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-18-2007, 04:27 PM
What u talkin bout willis

 
Join Date: Oct 2007
Location: BELTON, TEXAS
Posts: 2,724
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via AIM to REDPOWERSMOKER Send a message via Yahoo to REDPOWERSMOKER
7.3 No power

ok driving down the road nticed a small miss almost unnoticabel reved up motor white smoke came out of tail pipe and the truck just looses all power push on the fuel pedal and nothing but a really wierd grinding noise and truck lopes real bad and it dies any help need asap daily driver 254-421-2574
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-18-2007, 04:32 PM
What u talkin bout willis

 
Join Date: Oct 2007
Location: BELTON, TEXAS
Posts: 2,724
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via AIM to REDPOWERSMOKER Send a message via Yahoo to REDPOWERSMOKER
HERE IS A VIDEO
Attached Files
File Type: mpeg 12-18-07_1741.mpeg (152.0 KB, 36 views)
Reply With Quote Quick reply to this message
  #3  
Old 12-18-2007, 04:38 PM
She's paid for!!!!!!
 

Join Date: Apr 2007
Location: Roanoke, TX
Posts: 660
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Just a shot in the dark, what does your boost guage read, do you have a way to read any codes? I'm thinking turbo, but not sure. Hopefully one of the techs on here will offer some advice
Reply With Quote Quick reply to this message
  #4  
Old 12-18-2007, 04:40 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: Indiana
Posts: 564
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
man that sounds bad hope someone can help ya out bump bump
Reply With Quote Quick reply to this message
  #5  
Old 12-18-2007, 04:45 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: murfreesboro TN.
Posts: 885
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like your missing on more than a few cylinders. possibly uvc harness ??? what codes do you have
Reply With Quote Quick reply to this message
  #6  
Old 12-18-2007, 05:33 PM
What u talkin bout willis

 
Join Date: Oct 2007
Location: BELTON, TEXAS
Posts: 2,724
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via AIM to REDPOWERSMOKER Send a message via Yahoo to REDPOWERSMOKER
NO CODES NO NOTHING I CANT GET IT TO REV UP ENOUGH TO GET A BOOST READING
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors