PLEASE HELP!! E99 runs really rough!! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-14-2013, 03:04 PM Thread Starter
Member
 
Join Date: Feb 2011
Location: Cape Cod, MA
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
PLEASE HELP!! E99 runs really rough!!

Hi guys! I have an e99 7.3 and after 25hrs of plowing she sputtered and stalled. I checked everything. Oil level is great. I replaced the outside plug of the UVC harness cuz when I played with it she died. Changed the fuel filter. Full tank of fuel. Checked the FPR. I am in the middle of pulling my sending unit from truck now. She starts up fine and idles great. As soon as you give her any pedal she pops and farts and don't have any power. Please guys I have to fulfill a plow contract with my town and its supposed to snow Saturday night. All help is greatly appreciated. Call my cell as I'm trying to troubleshoot the truck. 1-508-326-4009


Sent from AutoGuide.com App
FordPowerStroke1986 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-14-2013, 05:39 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
hutch mod

Welcome to guzzle's In-tank Hutch Mod Web Page

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 6 Old 02-14-2013, 05:43 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
50 cent mod

Sorry Mods for posting another site, but its the only "good read" i found...

50 cent mod - Ford Truck Enthusiasts Forums

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #4 of 6 Old 02-14-2013, 06:09 PM
Powerstroke.org Fanatic
 
Join Date: Mar 2011
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
fuel pressure? if you don't have a gauge i'd hook one up and check out what your fuel pressure is at idle and see if you can catch what it is when you give it some gas before it stalls.

02 F250 7.3 Ext. Cab Long Bed
6637 DIY intake, muffler delete, EBPV delete, 6.0 cooler, ISSPRO gauges
285/75/16 BFG a/t's
lakailimited06 is offline  
post #5 of 6 Old 02-15-2013, 09:10 AM Thread Starter
Member
 
Join Date: Feb 2011
Location: Cape Cod, MA
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
PLEASE HELP!! E99 runs really rough!!

Pulled the sending unit and found the two screens inside that mixer all plugged up. I am going to do the hutch mod soon. Not enough time today. Put everything back together and test drove. Truck seemed to still have the problem at acceleration just not nearly as bad. While truck was at idle I pulled the plug from the IPC sensor and then drove around some more. It seemed to go away after that what you guys think??


Sent from AutoGuide.com App
FordPowerStroke1986 is offline  
post #6 of 6 Old 02-16-2013, 07:52 PM Thread Starter
Member
 
Join Date: Feb 2011
Location: Cape Cod, MA
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
PLEASE HELP!! E99 runs really rough!!

Passenger side UVCH was the problem! Luckily I had a brand new set and replaced it in under 2hrs!!


Sent from AutoGuide.com App
FordPowerStroke1986 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome