7.3L runs rough,then stalls - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-26-2007, 04:35 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Location: Midwest
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation 7.3L runs rough,then stalls

Hi, I have a 1995 F250 powerstroke with dual fuel tanks. The problem I have been having is when I drive down the road with the fuel tank slector on the front tank, It somtimes will start to run rough, so rough infact that the steering wheel will start to shake, and it loses all power. I can pull over on the side of the road and it shakes like it is only running on 6 cylinders or less, then I swicth the fuel tank selector to the rear tank and after 6 seconds it runs just fine. The problem is intermitent because somtimes I can drive 40 miles on the front tank and have no problems, other times I can only drive 2 miles and it starts, but as soon as I switch tanks it goes away. Now, I replaced the tank selector assembly and also made sure that the pickup and return lines were not plugging up in the front tank. The front tank is plastic, so there can't be rust in there, And I never have any leaks anywhere. Fuel filter has 5,000 miles on it, and also it does'nt seem to matter if the tank is full or not. I hope someone can help, cause it is driving me crazy. Thank you.
7.3 max is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-26-2007, 04:47 PM
Desert Shield/Storm Vet

 
vitalidle's Avatar
 
Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hmm maybe sucking air

2002 F-250 4x4 EC, SRW, SB
Auto 93,000 miles
DP Tuner F5
ATS Compressor and 1.0 Exhaust housing high flow back plate
Turbo Back 4" Silverline Exhaust Mbrp Muffler Delete
Isspro Trans,Pyro,Boost Triple Pod
Fumoto Oil Drain Valve
AIH Delete With Boost Fitting


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
vitalidle is offline  
post #3 of 3 Old 11-27-2007, 02:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Location: Midwest
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thats what I thought, but if it was sucking air somewhere it should cause it to run bad all the time, and not just once every so often, shoud'nt it?
7.3 max is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome