Slight miss, loosing boost? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-25-2013, 04:07 PM Thread Starter
Join Date: Apr 2011
Location: Hillsboro, TN
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Slight miss, loosing boost?

I just bought a 99 7.3. It runs smooth, but it looses tons of boost going from first to second, it doesn't seem right at all, but this is my first 7.3 my 6.0 doesnt act anything like this is why im asking. The turbo spools up well in first and then when it shifts to 2nd you can hear the turbo sound like the exhaust is holding it back, and the motor is pretty sluggish. Also it has a slight miss at idle after giving it hell, but it clears up if just being easy. could the turbo issue be the EBPV or is this normal on 7.3s.

Thanks guys, jbb
jbb421 is offline  
Sponsored Links
post #2 of 2 Old 01-25-2013, 07:54 PM
Compression Ignition Addict
Join Date: Apr 2012
Posts: 1,113
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
have you checked for codes?

the richest ones are not those who have the most, but those who need the least
kaya@bernhausen is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome