white smoke, engine runs rough...rookie needs help - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-21-2013, 07:22 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
white smoke, engine runs rough...rookie needs help

I have a 99 f 550 7.3 with 200,000. Just recently the fuel system was contaminated with engine oil. I replaced all 8 injector seals and cup sleeves. Replaced the rail fuel pump and fuel filter. The contamination is fixed, but after a couple of the days of using the truck it made a hissing noise from the turbo and just started running rough with heavy white smoke. It wont go away when engine is hot. It ran rough the first time i started after i completed the job, but it went away. now its back for good!!! I have a modis scanner to use, but not sure what to look for. I know of the buzz test, but if that is ok what else do i need to look at! Any info will be appreciated.....
v-DOGG is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-21-2013, 09:01 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anyone??? Please....
v-DOGG is offline  
post #3 of 4 Old 02-08-2013, 06:21 PM
Powerstroke.org Fanatic
 
boatnut1978's Avatar
 
Join Date: May 2008
Location: Walker county Alabama
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have you had any luck with your truck??

I am having a similiar problem..

1999 F-350 CrewCab SB 7.3 International
5" Exhaust, Ford Fleet intake (huge)!!!
Map fooler, blow off valve cheeter, Dfuser tuner (looking for a better one..lol)
6" lift, 35" TOYO MT'S on 18" Venti's

Knocking in the front and Smoking out the back!!!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
boatnut1978 is offline  
post #4 of 4 Old 02-08-2013, 09:34 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes i did....number 5 cylinder rocker arm bolts for intake side broke off. used a cheap torque wrench to torque all the rocker arm bolts. thank god i was able catch this before all of them came loose. I learn its better to buy a better brand of torque wrench instead of a cheap one. Runs like a champ now...
v-DOGG is offline  
Sponsored Links
Advertisement
 
Reply

Tags
rough , white smoke

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome