7.3 hard start, rough idle, idm codes, new Pensacola injectors - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-08-2013, 12:44 PM
Premium Member
 

Join Date: Aug 2012
Location: Greeley, CO
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 hard start, rough idle, idm codes, new Pensacola injectors

My friend has an 03 7.3 that is giving him problems. The truck had 220ish thousand miles, superchips tune, new PCM and just put in remaned injectors from Pensacola.

He replaced the injectors because it had starting issues and was sluggish driving. The new injectors fixed his starting and power issues. He put a few hundred miles on it and then blew out the top radiator hose. He immediately pulled over shut it off and hauled it home. When he got coolant back in it and replaced all the coolant hoses it ran funny.

The truck was hard to start, it has to be turned over for a long time before it will fire and when it does it runs rough and has much less power than it should. I have AE on my laptop and have done all the tests. Buzz passes and injectors sound good, contribution is ok but it threw an idm code I think it was 1316 can't remember for sure. I researched the code and everyone seemed to conclude that a new idm would fix it. I found him a good used idm, guy said it came out of a running wrecked truck. He put it in and started it up. Everything was back to normal, it idled normal and was easier to start. He hooked it to a stock trailer and drove off. A few miles later he pulled into a field and hit a soft spot, when he gave it some fuel to pull out it stuttered blew out a bunch of black smoke and went back to running rough. Now it is back to the way it was before, hard start and rough running. He had a guy hook it up to a snap on scanner and its the same story, passes tests and it shows 1316 code.

I have read that the injectors he bought are not the best but I'm not sure they are the problem. By the way they are stock size injectors. Any help or suggestions would be great.

Thanks,

Barrett
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-15-2013, 12:19 PM
Member
 

Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would pull the valve covers and make sure the harnesses are in good shape.
Reply With Quote Quick reply to this message
  #3  
Old 01-15-2013, 12:38 PM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 453
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
We've used Pensacola injectors twice and had problems both times. When we put in known good injectors the problems went away. Don't want to bash anyone but we won't use them anymore.

Sent from my SPH-D710 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #4  
Old 01-15-2013, 03:45 PM
Premium Member
 

Join Date: Aug 2012
Location: Greeley, CO
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the responses. He did ohm test the harnesses, injectors and glow plugs through the uvch plug in everything checked out, I can't remember what the glow plugs registered but the injectors were between 3.1 and 3.2. I had not herd of Pensacola injectors until he bought his and started having problems, and ya, I haven't read many good things. Would injectors ohm test, not lose oil and still be the source of his problems? Also could he have something cooking the idm?
Reply With Quote Quick reply to this message
  #5  
Old 01-15-2013, 04:14 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: FL
Posts: 4,220
Thanks: 20
Thanked 26 Times in 17 Posts
Feedback Score: 0 reviews
I'd put my money on the injectors. Read far more negative feedback about that company than positive.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
1316, hard start when cold, idm, power loss, rough idle

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:02 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors