Injection wiring harness question - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-27-2012, 11:16 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injection wiring harness question

So I replace the wiring harness and valve cover gasket when I replaced the injector cups. I keep getting P1316 code so took to ford to hook to computer. Told me had codes and on all but two injectors said to check connections. I checked all the connections everything was connected. No wires are pulled out or anything. Still getting codes. Engine idles little rough but doesnt seem to have lack of power just lack of mpg. Down to bout 10 from 15 before. I put my programmer on it again and still get 1316 code. What else can I check or do.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-27-2012, 07:16 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 1,065
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how does it fire up cold?
once running, how does it run cold?
why did you replace the gaskets?
was the code present prior?
what's the mileage on the vehicle?
have the injectors been replaced before?

answer each of those questions if you can, please
Reply With Quote Quick reply to this message
  #3  
Old 12-28-2012, 05:09 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Starts as good as any 7.3 I been around. Just smokes heavy after fire up. Runs fine cold. Replaced injector cups and o rings on injectors and glow plugs thats why new gaskets. SES light always been on but no reader and didn't take to ford and has 118,000. Looks like one injector has been replaced cause its diff from the rest.
Reply With Quote Quick reply to this message
  #4  
Old 12-28-2012, 05:14 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,007
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
#8 injector will be different from the factory.
If the light has always been on and you didn't scan it, you can't assume that the UVCH was going to fix it.
Test need to be run, not just codes scanned in order to figure out what the issue is.
Did you replace/check the UVCH connectors that are on the motor side of the wiring harness?
Reply With Quote Quick reply to this message
  #5  
Old 12-28-2012, 08:40 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 1,065
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i will assume that ford ran a buzz test on the injector circuits. the fact that it fires up and runs decent cold does not point towards 6 failing injectors. it would be great if you could get ahold of a test idm, connect it, and run the buzz test with the test idm to see if the results differ
Reply With Quote Quick reply to this message
  #6  
Old 12-28-2012, 08:41 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I didn't replace the wiring harnesses to fix the problem I did it as maintence. This moring driving to work it lost power completely but wasn't missing just no power and high egts with smoke. Then like something came free it came back and ran just fine. I don't know whats going on. yes ford did the buzz test and checked idm and said that was good. Guess I am going replace the cps and clean the ebps this weekend and see if that helps
Reply With Quote Quick reply to this message
  #7  
Old 12-28-2012, 08:42 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is there anyway it could be the idm?
Reply With Quote Quick reply to this message
  #8  
Old 12-28-2012, 09:31 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 1,065
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ohhh i see. reread your initial statement. ford said it had codes on 6 injectors. what were the results of the buzz test then? did any of them fail?
Reply With Quote Quick reply to this message
  #9  
Old 12-30-2012, 09:15 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
according to them all passed. I just cleaned the ebps sensor and tube yesterday. the sensor was completly blocked with soot. The tube didn't seem clogged but cleaned it and sensor so I guess I will see if that does anything. Cam positon sensor this week when it gets here. I hope something works
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors