alternator bad or gauge? - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-22-2012, 04:39 AM Thread Starter Rookie
Join Date: Jul 2012
Location: wartburg
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
alternator bad or gauge?

Yesterday it was cold so i cranked n cranked til my batteries were too low so i put it on a slow charge while i plugged it up. it sat for two hours on a slow automatic charge. when i cranked it it was ok for a while then while i was driving home my gauge shot up to 18 volts!! So i made it to advance and they tested it and said it was ok but wasn't positive about the regulator..

~7.3 4door 4x4 6speed~
Duncan563 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome