Died on me on the way home.. wtf? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-10-2012, 06:05 PM Thread Starter
Member
 
Join Date: Mar 2012
Location: lincoln Rhode Island
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Died on me on the way home.. wtf?

Ok so on the way home tonight,I stopped at a shop to discuss building my d60 swap. Truck ran fine from work to the shop, bout a 10 min ride. I go to leave the shop and pull out onto the main road,and about a minute later, it starts running like crap cutting out and what feels like misfiring. At the next light it stalls, I start it back up and it fires right up, but about 3 seconds later starts running like crap and tries to stall.

I nursed it to my old highschool's parking lot where i changed the fuel filter with a buddies spare. Try starting the truck, and it still starts fine, just won't stay running for more than like 5 seconds after firing up. I had to get towed home, and it still fires right up but won't run for more than a few seconds.

I'm thinkig IDM or something in the wiring for the IDM? Possibly the fuel pump? It's wet outside so maybe water got in the IDM and messed it up? i've heard of that happening.

1995 Blue RC Utility body, 125k AFE Intake, 3" down pipe, South Bend OFEK Clutch, Cobalt Gauges, Boost, Oil temp, EGT.
Future: Dana 60 swap, Pickup Bed, Intercooler, new Rad. support.
jeremie444 is offline  
post #2 of 4 Old 12-10-2012, 08:15 PM
Compression Ignition Addict
 
atvrider93's Avatar
 
Join Date: May 2010
Location: Raleigh, NC
Posts: 3,835
Thanks: 12
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
check uvch connections

1996 F350 4x4 CCLB-- I'll miss her

1996 F350 4X4 RCLB zf5 213K
6637
OBA w/horn
DE 5"
PHP tunes
Mud Country 315/75/16

2008 Wr250X

Quote:
Originally Posted by belz View Post
There u go Tom. John may not be sexy, but he can tutor you, lol.
atvrider93 is offline  
post #3 of 4 Old 12-10-2012, 09:15 PM
Powerstroke Techie
 
Join Date: Apr 2012
Posts: 2,149
Thanks: 43
Thanked 78 Times in 78 Posts
Mentioned: 39 Post(s)
Quoted: 100 Post(s)
Feedback Score: 0 reviews
^^absolutely agree. but i'd check the codes first. always the best place to start

the richest ones are not those who have the most, but those who need the least
kaya is offline  
post #4 of 4 Old 12-11-2012, 04:30 PM Thread Starter
Member
 
Join Date: Mar 2012
Location: lincoln Rhode Island
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
UVCH connections? under valve cover harness connections?

They're all tight, at least where the outside harness meets the valve cover. Should i pull the valve covers and see if there's anything loose under there? Do i need to replace the gasket/harness's when i do this?
The CEL isn't illuminated, and didn't come on when the truck started this.

I thought it was my IDM, changed it out with a buddies and still did the same thing. Could my lift pump be going bad? Whats the pressure at the fuel bowl supposed to be(schrader valve)?

Just noticed this is in the wrong section could a Mod move it for me?

1995 Blue RC Utility body, 125k AFE Intake, 3" down pipe, South Bend OFEK Clutch, Cobalt Gauges, Boost, Oil temp, EGT.
Future: Dana 60 swap, Pickup Bed, Intercooler, new Rad. support.
jeremie444 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome