ICP sensor ? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-22-2012, 12:06 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2012
Location: Edwardsville, IL
Posts: 197
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 4
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
ICP sensor ?

Hey all and happy Thanksgiving.
Been having a problem with cold start and long clear up after it does start.
I have replaced the gpr, 8 glow plugs and the uvc wiring harnesses. I pulled the plug out of the ICP and found oil up in the plug. From what I have read this is a good indication that the ICP is dew for a change. Is this the case? If I plug the block heater in the cold start problem and rough running goes away so I just figured it was still a glow plug problem. Once the truck is up to temp it does just fine. Any input would be great. I have been going through a list of items to get this truck up to snuff having just purchased it.
Thanks for any help.
welove2drive is offline  
post #2 of 4 Old 11-22-2012, 06:44 PM
Compression Ignition Addict
 
blue99stroker's Avatar
 
Join Date: Oct 2011
Location: Chico, California
Posts: 4,820
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
Thanks: 18
Thanked 191 Times in 183 Posts
Feedback Score: 0 reviews
yep time to change
the icp isnt sending correct information on oil pressure. which is vital at startup.

99.5 f250 7.3 4x4 255k
PHP Phoenix, S&B, 4" Diamond Eye, Hpx, Stancor, RR Billet Wheel, RR AIH Delete, Autometer Gauges, Pro Comp leveled, Transgo Tugger, Billet TQ Converter, Warn Hubs, Int'l Up-Pipes, RR IC-Boots, Non-Ebpv Pedestal, High Flow Outlet, Hucorey's HPOP Lines, RR High Flow Fuel Fittings, RR OCR, Barder 360 Thrust Kit, 08 Tow Mirrors.

Dad-2000 7.3 108k miles, Autometer Gauges, Superchips 1705, RR AIH Delete, 6637, 4" Diamond Eye, BD Billet Wheel, TruCool Max
blue99stroker is online now  
post #3 of 4 Old 11-22-2012, 07:21 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2012
Location: Edwardsville, IL
Posts: 197
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 4
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Thank you for the reply. I was hoping I was on the right track. Have to get one coming before it gives up completely.
welove2drive is offline  
post #4 of 4 Old 11-26-2012, 07:47 PM
Compression Ignition Addict
 
Eco Taxi's Avatar
 
Join Date: Aug 2011
Location: iowa
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I'm in the exact same boat - I've replaced both batteries, alternator, gpr, all glow plugs, starter, starter solenoid, fuel filter
.... Check your exhaust back pressure sensor I had to clean mine out but my ICP had oil on it too so that's next
Eco Taxi is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome