Loud engine quiet turbo. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-06-2012, 01:30 PM
Member
 

Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loud engine quiet turbo.

My truck has been running different lately. The injectors seem really loud you can barely hear the turbo until over 2k Rpms and it is getting horrible fuel economy. The up pipes are not leaking. The oil fuel and air filter are brand new. Can anyone suggest what to start checking?


Sent from my iPhone using Autoguide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-06-2012, 03:34 PM
Compression Ignition Addict
 

Join Date: Dec 2011
Posts: 248
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wish I could help, but all I can do is subscribe.
Reply With Quote Quick reply to this message
  #3  
Old 11-14-2012, 09:40 AM
Member
 

Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was checking around again today and found the top rear bolt missing and thge lower rear bolt backed all the way out against the mounting bolt. The center section is covered in oil as well. Is it possible that these loose bolts are killing my boost?
Reply With Quote Quick reply to this message
  #4  
Old 11-17-2012, 08:42 PM
Powerstroke.org Rookie
 

Join Date: Jan 2009
Location: kansas city
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine seems to be having the same problem the engine is loud and my turbo seems to be slow to build boost. If you figure it out please let me know.
Reply With Quote Quick reply to this message
  #5  
Old 11-18-2012, 05:47 AM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've got the same problem on my Excursion. Turbo is pretty quiet and dropped about 3mpg. Cannot figure it out!
Reply With Quote Quick reply to this message
  #6  
Old 11-18-2012, 06:45 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: Texas
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The turbo might be goin out.
Reply With Quote Quick reply to this message
  #7  
Old 11-18-2012, 07:11 AM
Member
 

Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The shaft spins freely with no excessive play.


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
  #8  
Old 11-18-2012, 10:46 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: Texas
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well I believe there is a sliencing ring inside the intake side of the turbo which quiets the turbo a bit. I took mine out and I got a nice whistle now.
Reply With Quote Quick reply to this message
  #9  
Old 11-18-2012, 06:53 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Posts: 302
Thanks: 2
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Dirt rider1 View Post
Well I believe there is a sliencing ring inside the intake side of the turbo which quiets the turbo a bit. I took mine out and I got a nice whistle now.
Not to high jack this or anything but what does this ring look like I would like more whistle out of my truck
Reply With Quote Quick reply to this message
  #10  
Old 11-18-2012, 08:02 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,071
Thanks: 0
Thanked 14 Times in 14 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Dirt rider1 View Post
Well I believe there is a sliencing ring inside the intake side of the turbo which quiets the turbo a bit. I took mine out and I got a nice whistle now.
A 7.3?





Quote:
Originally Posted by Dirt rider1 View Post
The turbo might be goin out.
No.

leaking exhaust, leaking boost, or ebpv stuck closed.

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:43 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors