Low boost, no power...Is my turbo done??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-05-2012, 07:51 AM
Powerstroke.org Rookie
 

Join Date: May 2011
Location: Spring Hill, KS
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Low boost, no power...Is my turbo done???

As of yesterday morning my truck became a 4cyl...I started it up and it runs fine, but has no power. When I floor it, the pyro hits 1200 easy and I only get 5psi boost. This just started yesterday. Last week I drove to Oklahoma and back (750mile round trip) and it ran between 1000 and 1200 the whole trip, which I thought was a little high. I started to check for boot leaks, but nothing visual. Going to do more investigation tonight. No check engine light and barely any turbo whistle. Please help. Thanks for any advice.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-05-2012, 10:04 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,037
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Check the shaft for play. Ebpv might be stuck closed.

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
  #3  
Old 11-05-2012, 03:45 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Location: Garneill, MT
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have had the same problem with my pickup. Change the IPR valve! Word of advice though, pay the extra 30 bucks and buy one from FORD. I bought mine from napa and it is currently running like **** again.
Reply With Quote Quick reply to this message
  #4  
Old 11-05-2012, 04:43 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Dover
Posts: 1,618
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pull the intake off and check that turbo shaft end play and side to side.

Any exhaust leaks before the turbo?
Reply With Quote Quick reply to this message
  #5  
Old 11-06-2012, 05:14 PM
Member
 

Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My truck is doing the same exact thing. No exhaust leaks, no shaft play, spins freely, ebpv is unplugged. I don't hear the noise from it is it possible it can be stuck closed a little? My turbo makes hardly any whistle unless I stand on it?
Reply With Quote Quick reply to this message
  #6  
Old 11-08-2012, 09:06 PM
Powerstroke.org Rookie
 

Join Date: May 2011
Location: Spring Hill, KS
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got under the hood tonight after my intercooler boots came in from riff raff. Installed the new boots and started the truck. My turbo is back in action and it runs better, but still not the power it should have. Gonna change the fuel filter over the weekend and see if it helps. Also, thinking about cleaning the ebp tube and sensor. The intercooler boot on the driver side was blowing by on the bottom and had the intercooler covered in S***!!! I'll let you guys know what happens. Thanks again.
Reply With Quote Quick reply to this message
  #7  
Old 11-12-2012, 05:41 PM
Powerstroke.org Rookie
 

Join Date: May 2011
Location: Spring Hill, KS
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So after more crawling around on and under the truck, I found I have the almighty up pipe leak on both sides...explains a lot. Anyhow, I bought the gaskets(fel pro 8194) and am going to replace them this week. Thanks again for all your help.
Reply With Quote Quick reply to this message
  #8  
Old 11-12-2012, 05:47 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Dover
Posts: 1,618
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No prob man.
Reply With Quote Quick reply to this message
  #9  
Old 11-20-2012, 08:41 PM
Powerstroke.org Rookie
 

Join Date: May 2011
Location: Spring Hill, KS
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So after new intercooler boots, new up pipes, and re sealing the turbo o rings, plus adding the riff raff frx, my girl is alive again and runs better than she has in a long time. Thanks for all the help and I can't wait for the weekend to really get her out and open her up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:18 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors