Engine skips a beat or dies - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2012, 03:39 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine skips a beat or dies

So I just bought my first diesel, a 2000 f250 7.3 4x4 zf5 with about 122k miles. But the engine is doing something weird. On one day I made about a 200 mile highway trip empty and twice on the return leg within about 20 minutes of each other, the engine felt like it skipped a beat. RPMs dropped suddenly like the engine shut off, but a fraction of a second later it was running fine. Then today I had it happen to me more, on my way to work I was coming up to an intersection where I had to turn, I was already moving a bit so I was working the clutch a bit in 2nd before the turn. Right before I made the turn it skipped a beat again but this time I was already so low in the RPMs that it stalled and shut off on me. Pulled it off to the side, took the keys out then put them back in and it started just fine. Then later today I had it happen another 4 times. Once city driving in 3rd going up a hill, next on the highway doing 60, then in idle at a stop light. It almost shut off that time (went down to 200 RPM) Then lastly it skipped a beat again in my driveway as I'm reversing. This last time it shut off on me again.

What's going on with my truck?

I'm not mechanically inclined so please no acronyms and try to explain it to me like I'm an idiot. Truck is bone stock as far as I know.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-29-2012, 12:26 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have an update on the problem. Today was driving again and it continued to do its hiccup/skip a beat. On one of the last times it did this, the check engine light came on. I was on my way home so I stopped by auto zone to see if I could get a code. But for some reason their code reader wouldn't sync up with my trucks computer. So now I have a check engine light on on top all it all.

I've been doing some reading and hoping its just the CPS and nothing major. Can anybody shed some light on this
Reply With Quote Quick reply to this message
  #3  
Old 11-02-2012, 10:37 AM
Compression Ignition Addict
 

Join Date: Apr 2009
Location: blackwell TX
Posts: 199
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem with my 01 and now it will start but I have no throttle
Reply With Quote Quick reply to this message
  #4  
Old 11-02-2012, 03:34 PM
Powerstroke.org Rookie
 

Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Without a doubt, replace your CPS (sometimes called CMP) cam position sensor. I use the dark blue one from International. THE ford one is gray. It has one bolt and one connector. Takes about 15 minutes and costs $25-45 depending on the store. Do a search on CPS on this forum, or Youtube for instructions. You can see from the bottom passenger side. all you need is 10mm socket with a 3in extension, and maybe a flathead screwdriver to pry a little. Tends to pretty stiff at first, but just rotate it back and forthe and pull straight out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:18 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors