Few Questions on my 01' 7.3.. - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-23-2012, 10:48 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Few Questions on my 01' 7.3..

Hey all! Just bought this truck a few weeks back, and mostly all seems well. It is a 2001 F250 4x4 with 200K, has a trans from Twisted Diesel, AFE intake, turbo back exhaust, Edge insight PDA and TS 6 pos chip.

I've found this Edge PDA to be quite useful, however I think maybe it's causing me to worry about the truck more than necessary. It seems wicked fast, shifts great, no CEL or anything like that... However, the PDA popped up the DTC P1211 (ICP fault?). I have the ICP psi as one of my optional gauges, which reads around 480 at idle (should be around 500?) The injector pulse width ranges between 2.0 - 3.5 or so throughout the powerband, as well as in park. I was told that "within parameters" is -4.0 - 4.0, is this correct? The truck seems to idle a bit shaky, but maybe it's just me.

Just feeling out a new truck and making sure I don't have much to worry about.

Thanks in advance =)

e99' PSD, CCSB, 245xxx and counting
tvoymang is offline  
post #2 of 5 Old 10-23-2012, 10:54 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
congrats on the ride, mang.. I'd locate the icp and unplug it. See if theres oil in the plug / connection. If so, it needs replacing.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 5 Old 10-23-2012, 12:25 PM
Compression Ignition Addict
 
LakiPolitis's Avatar
 
Join Date: Dec 2011
Posts: 248
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by timmyboy76 View Post
congrats on the ride, mang.. I'd locate the icp and unplug it. See if theres oil in the plug / connection. If so, it needs replacing.
You can try to clean it out with brake cleaner and see if that changes your readings, but like timmyBoy said, just order one of eBay ($65 - $80). It's your best bet.
LakiPolitis is offline  
post #4 of 5 Old 10-23-2012, 12:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So is 480 too low? Or would that be considered OK? I will check the ICP for oil when I get home today and report back.

e99' PSD, CCSB, 245xxx and counting
tvoymang is offline  
post #5 of 5 Old 10-26-2012, 11:33 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the feedback guys. I have another question... Is there any way at all to tell whether the truck has newer/upgraded injectors in it, without opening it up? It just seems unnaturally quick, and being the other upgrades its got I wouldn't be totally shocked.

e99' PSD, CCSB, 245xxx and counting
tvoymang is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome