Bad sound under load - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-18-2012, 07:44 AM Thread Starter Rookie
Join Date: May 2008
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad sound under load

2001 F350. When under a heavy load pulling a trailer Wot or close ( like up a hill) I get a sound that is like a brake pad when it is squeaking from a wear sensor. I can ease off the pedal a little and it will go away. It only does it when the engine is at temp and I am pulling a heavy load. I have also noticed that I am a little down on power not alot just alittle. I am thinking about replacing the turbo but dont want to if i dont need to. Whats the general consensus
shieldsrs is offline  
Sponsored Links
post #2 of 2 Old 10-18-2012, 02:24 PM
Compression Ignition Addict
timmyboy76's Avatar
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
CRAZY...heard the same thing coming back from the river. Pulling the hill with my boat. Never had heard it b4, and yet to replicate it, under no load.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome