99 7.3 P1670 memory code - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-18-2012, 06:01 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2012
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 7.3 P1670 memory code

I have a 99 7.3 with codes P0344 and P1670 in memory, it runs but sometimes stalls. When it stalls it's like I turned off the ignition, it restarts like nothing is wrong. It doesn't always do it, in fact I've driven it every day this week trying to fix it, but it doesn't stall on me.

Any ideas?

I replaced the cam sensor and IDM, tapped wiggled and jiggled the harness connectors, I still haven't been able to find anything.

Actually, it's a 6/98 build date. How do I move this to the 98 forum?

Last edited by kx50002; 10-18-2012 at 07:25 AM.
kx50002 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome