Hard Start/rough idle when warm - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-15-2012, 07:56 AM Thread Starter
Join Date: Nov 2010
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hard Start/rough idle when warm

I have an early 99 with 156K miles. I put a new 17* HPOP in it last spring. Ever since then every once in awhile it takes forever to start after its been driven. It doesnt do this all the time. It starts awesome cold, idles great and it has awesome power. After it has been driven it idles like crap, and starts really hard but seems to have awesome power.

I have pulled the IPR and cleaned it up, waiting now for the new o-rings to put it back together. The old o-rings looked fine, no cracks etc. Could there be a problem with the 17* hpop that I put in it ? It was a remanufactured one I purchased from Ebay. Thanks in advance.
mythreesons is offline  
post #2 of 2 Old 10-17-2012, 08:58 PM
Powerstroke.org Rookie
Join Date: Mar 2012
Location: Corona, Ca
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That sounds more like a internal oil leak. I'm not sure if the 7.3 has dummy plugs, but that is the common cause for hard or no stars when the 6.0 is warmed up. I can do more research and get back.
efw is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome