7.3 Turbo trip to beach - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-08-2012, 04:05 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2012
Location: Fountain Inn SC
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3 Turbo trip to beach

The trip to the beach is a 500 mile round trip, i was hauling my truck camper and pulling the boat. Not one problem going down and most of the way coming back. Then the Service Engine Soon Light came on, the engine didn't lose any power, but when i stopped the engine would lope then stop running, but it would start again.

The truck has 225,000 miles, the Injectors were replaced about 5000 miles ago and the wiring harness was replaced less than 2000 miles ago.

A lot of smoke when the engine restarts.

all of the other post indicates loss of power and vibration, but this is not my case.

Haven't got a CODE yet, any ideas??
Hawnt1 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome