Fuel pump problem - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-27-2012, 04:44 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Fuel pump problem

2003 F250 7.3
going up a hill lost power, tried to start sounded like valve knock, barely idle,
then quit, waited about 1 hour started still very rough went about 2 miles barely then quit. towed home.
changed filter
turned key off and on 3 times no sound from pump no fuel in bowl
anything is their a fuse or relay that could be bad?
or just the pump?
dark and quiet now, turned ign on and heard click but no whirr

Last edited by jrc4652; 09-27-2012 at 05:16 PM.
jrc4652 is offline  
post #2 of 4 Old 09-28-2012, 06:46 AM
Compression Ignition Addict
timmyboy76's Avatar
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
fuse #30, 30amp fuse. If popped, unplug the fuel bowl heater. More than likely, thats what shorted out..(common problem ,from what i've read). Have you looked into the Hutch mod...?

Welcome to guzzle's In-tank Hutch Mod Web Page

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 4 Old 09-28-2012, 06:51 AM
Compression Ignition Addict
Join Date: Dec 2007
Posts: 6,357
Thanks: 7
Thanked 262 Times in 253 Posts
Mentioned: 7 Post(s)
Quoted: 111 Post(s)
Feedback Score: 3 reviews
The pump is controlled by the PCM. If your Fuse #30 was blown you'd have no WTS light because the PCM isn't powered-up and the pumps relay isn't throwing.

From there, the next thing to look at is the Inertia Sw (pass kickpanel) for being either unplugged or tripped. Then, the pump itself might have died (check for power down at the pump).
NoRalPh is offline  
post #4 of 4 Old 10-01-2012, 04:26 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok finally able to get a day to work on it.
first took pump off and hooked it up to battery, it was bad
dropped tank,screen was broke off got one at ford house, cut off filler and vent tube as per Welcome to guzzle's In-tank Harpoon Mod Web Page
then reassembled and cycled 4 times and cranked and it started right up
thanks for the replys I did check the fuse first
jrc4652 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome