NO oil in hpop resevior - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-20-2012, 07:45 AM Thread Starter
Powerstroke.org Rookie
 
Ford-tough's Avatar
 
Join Date: Apr 2012
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
NO oil in hpop resevior

I got a 02 7.3 and the hpop res drains off over night so then i get a no start. so i fill the hpop res up then it fires up and runs untell I turn it off and try to restart it then no start again, so I recheck the hpop res and its full still I put my mechanical high pressure gauge in the head on pass side and crank it I get 200-250 psi witch is not the 500psi i need to start. so after that i unplugged my ICP and cranked again, my pressure is more but just not enuff @300 to almost 400psi. I have a new hpop ICP and IPR in this thing Help lol thanks
Ford-tough is offline  
post #2 of 2 Old 09-24-2012, 12:06 PM Thread Starter
Powerstroke.org Rookie
 
Ford-tough's Avatar
 
Join Date: Apr 2012
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok I fixed it I had 6 and 8 injector o-rings blown out even thow there only a yr old. But they where not ford o-rings maby that's it owell.
Ford-tough is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome