Is this Fuel Related? fuel pump, high pressure pump? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-19-2012, 05:43 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy Is this Fuel Related? fuel pump, high pressure pump?

I have an 03 7.3 it has 155k on the clock. the other day i was driving it and out of nowhere it started running like ****. check engine light and huge power loss. It feels like every cylinder is misfiring. When you start it it runs fine for ten seconds and then starts choking like it is starving for fuel. My fuel gelled up last winter and it acted the same .way as when that happened. i naturally changed the fuel filter. the fuel filter has less than 5k on it. so im still gonna check it. whn the problem occured my fuel light had just came on maybe 3 miles prior to it malfunctioning. So i was wondering... being i was climbing a decent grade when the problem occured, could it have not had enough fuel pumping to where i essentially ran itself out of fuel even though there was fuel in the tank? Just trying to make sense of this issue. or could my high pressure fuel pump be fried. i dont think it would be the main one in the tank but who knows. Please help with any suggestions or comments you may have. it wont hurt. I just got laid off two weeks ago, so of course this would happen at a time like now. fml

Last edited by eric7770; 08-20-2012 at 08:14 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-19-2012, 05:55 AM
Guns & Powerstroke's
 

Join Date: Apr 2009
Location: North Central Oklahoma
Posts: 258
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Your pickup in your fuel tank is probably rotted and letting air in.
Reply With Quote Quick reply to this message
  #3  
Old 08-20-2012, 08:11 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well i checked the fuel bowl. it was completely full and filter is perfect. not a fuel issue. Its weird, ill cycle the key two or three times(full cycle of glow plugs) fire it up and it is fine for about a minute to 3 minutes then it starts choking again. when i cylcle it just once and fire it up it starts choking within 15 seconds. i unpluged the icp and it still acts the same. Im kinda suspecting the ipr to be the culprit but im not too sure about that either. Im probably gonna tear off the valve covers and make sure the harnesses are plugged in properly, although im really dreading this and im not sure its necessary being the 02 and 03 models have the revised harnesses to prevent the male and female ends from separating. Any suggestions at all?.....anybody?
Reply With Quote Quick reply to this message
  #4  
Old 08-20-2012, 10:54 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So i just went outside to scan it and i cannot get it to act up for the life of me. Runs like brand new....only thing i can think of is that when i checked the fuel filter the other day the lid came off with very little resistance and effort. at the time it caught me off gaurd, so now that im thinking more on it, i am guessing its possible that if the lid was not tight it could have been sucking air and building up air pockets. not sure if this diagnosis is accurate. let me know what you all think about this theory.
Reply With Quote Quick reply to this message
  #5  
Old 08-20-2012, 06:42 PM
Guns & Powerstroke's
 

Join Date: Apr 2009
Location: North Central Oklahoma
Posts: 258
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's possible but not probable IMO I would think that you would see fuel leaking if it was loose.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:36 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors