weird surge - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-14-2006, 11:07 PM Thread Starter Rookie
Join Date: Jul 2006
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry weird surge

ok guys maybe you all can help figure this out.I have a 99 f-350 7.3 4x4 auto with bullydog chip and i have a surge or a does it when it is getting upto speed and while at speed. It shows no codes and does not affect fuel mileage or power as i pull a pretty big GN trailer. but it feels like it is missing or surging getting up to and even while at cruising speed but it will run smooth when you really get on it so could this be the TPS or fuel water separater maybe .I have changed the fuel filter and cleaned and charged the air filter any help appreciated thanks
pacerman is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome