99 Ford 7.3 runs only on one bank - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-01-2012, 07:06 PM
Powerstroke.org Rookie
 

Join Date: Aug 2012
Location: Bloomingburg
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs down 99 Ford 7.3 runs only on one bank

i have a 1999 ford f-350 4x4 diesel 7.3 ,the entire driverside bank of injectors is not firing.the truck has a check engine light but my computer will not conect through any function.the truck runs verry rough and has absolutley no power.i pulled the wiring harnes off that bank and no change what so ever if i disconect the otherr side the truck will shut off.i removed the driverside valve cover to see if the conection with the internal wiring harnes was good the conection is tight and clean .if i give the truck fuel it will slowley raise the rpm gaudge and seems to run smoother but as soon as you let off it goes strait back to running rough and powerless.sometimes i notice white smoke when starting and it always starts hard.ive replaced the gasket/harness in the driverside valve cover also.i was thinking it had something to do with the wiring harnes leading to the injectors or the computer that controls it all,but then again if the computer was bad could it only cause one bank to go bad?some people have told me i may have a bad injector but removing the wiring hsarnes to the entire bank doesnt change anything which shows it is not running off any of them , anyone have any ideas on what might be wrong ,please help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-01-2012, 07:16 PM
Member
 

Join Date: Feb 2011
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Find another idm and swap it out, a bad idm will do the same thing
Reply With Quote Quick reply to this message
  #3  
Old 08-01-2012, 07:21 PM
Member
 

Join Date: Feb 2011
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Idm ( injector driver module) located in the drivers fender well.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
7.3 injectors, bad bank, diesel, runs rough, white smoke

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors