Misfire,boost problems,reverse light problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-26-2012, 07:50 AM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Misfire,boost problems,reverse light problem

Okay I have a 2000 F-350 7.3 with around 127k miles on it. I work at a dealership so i have access to a shop and tools. my truck started to misfire about 3 months ago and it wasnt all the time it was intermittent usually on light acceleration or when i maintain speed after accelerating. I pulled codes and it said #8 injector so I replaced it along with the gasket and wiring harness under the valve cover. About a week later the misfire comes back and has been doing it ever since sometimes its bad and other times it barely happens. I pulled codes about a week ago and i had a pcm failure so I replaced that and took out my banks six gun tuner. Before I pulled it out the tuner would say boost error and the turbo would boost while accelerating and then just drop and stop boosting. after I replaced the pcm and took out the banks the truck still misfires and shows a #8 injector code. I also cant get the truck to really get over 5lbs of boost and it runs very slow. No one at the shop can really figure out what is going on because it seems to be an electrical issue and theres no code that says just replace this and your fine it could be a number of things. But as of right now i have a new pcm, slightly new injector in #8 new wiring harness and gasket. Also every time i throw the truck in reverse it blows the fuse for the reverse lights and my vaccum pump is on that same fuse. I replaces the digital transimssion range switch and that didnt do anything. not really sure what to do with that im not too good with electrical things. Any help would be appreciated this issue has been going on for to long and it gets annoying because this is my daily driver.
thanks,
-Chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors