No insturments, No Throttle.... Please Help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-18-2012, 12:16 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No insturments, No Throttle.... Please Help

Hey Guys,

I have a 2001 F-450 7.3L

Problem = No Power to Instrument Panel, Throttle not responding.

After reading on the Fourms I found the root of the problem was an Exposed/Frayed Wire for the OD Switch in the steering Column.

I taped up the wires and replaced the #45 10amp fuse, however I'm still having the same problem but now the Fuse is not blowing out.

Before I could replace the fuse to fix the problem. As a Temp Fix so I could get it back to my Shop.

Anyone have any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-18-2012, 01:16 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,886
Thanks: 1
Thanked 89 Times in 84 Posts
Feedback Score: 3 reviews
Have you read through this:

https://b7445ba3-a-62cb3a1a-s-sites....attredirects=0

(it's got wiring diagrams and stuff in it...)
Reply With Quote Quick reply to this message
  #3  
Old 07-18-2012, 02:07 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Location: ft hood tx
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
had the same problem on my 02 250 i repaired the od wires with no luck ran a code reader and it turned up as a tps throttle positioning sensor luckily for me it was just the fuse i needed hope that helps
Reply With Quote Quick reply to this message
  #4  
Old 07-18-2012, 02:58 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for your responses guys.

All Fuses are Good, The TPS was replaced about 3 months back, and the Instrument Cluster is still non responsive.

Doe's anyone have a complete wiring diagram for the Model and Year?

My Mobile Diesel Mechanic and I think it is a problem with the fuse box? any thoughts?
Reply With Quote Quick reply to this message
  #5  
Old 07-30-2012, 08:46 PM
Member
 

Join Date: Dec 2009
Location: Pensacola, Fl
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same problem on my 01 Super Duty, when I would push OD it would kill everything had to replace entire clock spring to fix problem in addtion to shifter
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:48 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors