Boost?!?!?!? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-15-2012, 11:31 AM Thread Starter Rookie
Join Date: Apr 2011
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

Well to start off i drive a 2000 6 speed 2 wheel drive dually, i was driving on the highway a few weeks ago and the truck was running normal boosting fine just doing its thing, anyway i was going to pass someone so i got on it and it went into boost great then t spuddered and los power, felt like the boost just dropped off, i felt around on the cupplers and couldnt really feel any holes or slits but i will admit my cupplers arent very pretty. I went to my mechanic and he ran all codes and it brought nothing up including no pending codes. I have been driving the truck still and it hasnt spuddered since but it feels like it takes a while to boost, doesnt feel like it boosts under 2k and doesnt feel like all the piwer that it used to have is there anymore, ive researched and all i can find related to boost is with chips and stuff. Speaking of chips the truck is completly bone stock, the fuel filter has about 6k miles on it. Any help is appreciated here guys thanks!!!!!
240sxbubbs is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome