NO not my baby.... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2012, 09:11 AM
Powerstroke.org Fanatic
 

Join Date: May 2008
Location: Walker county Alabama
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
NO not my baby....

I was leaving ther boat launch yesterday going up a little hill and heard what I thought was one of my intake boots blowing off... lost power and barley made it to the top.
I pulled over and looked under the hood but did not see anything??

I limped home under no power and proceeded to check things out.
Found no oil on dipstick. put about 5qts in and test ran today.

Still no power, feels like no boost, but I still have not installed guages yet to tell.
She starts and runs fine at idel but just has no umph...

BTW, I looked in and saw that turbo was still turning just fine as engine was running... what do I look at now?


HELP PLEASE... I need the truck for my job... no truck... = no money
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2012, 01:21 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Posts: 837
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Was the truck blowing lots of smoke when it lost power?
Reply With Quote Quick reply to this message
  #3  
Old 06-29-2012, 02:11 PM
Powerstroke.org Fanatic
 

Join Date: May 2008
Location: Walker county Alabama
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No not blowing any smoke.

I am at a loss here...
Reply With Quote Quick reply to this message
  #4  
Old 09-15-2012, 04:58 AM
Member
 

Join Date: Jul 2012
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by ttyR2 View Post
Was the truck blowing lots of smoke when it lost power?
I have had this happen where I have no power at all when throttle is applied and a ton of smoke, grayish, it always happens at night. But the truck idels just fine. Do you know what causes this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors