Injector problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-28-2012, 11:31 AM
Powerstroke.org Rookie
 

Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injector problems

I hooked up the AE to my truck to start troubleshooting it. the problem is that when the truck gets up to operating temp it shuts off and wont start again till it cools off.

when it colds everything is fine and dandy but after it shuts down it only shows around 160 psi on the ICP. I have already replaced the IPR and it's doing the same thing and the ICP is functioning properly.

So I have a leak in the system somewhere when the oil gets to operating temp.

My question to you guys is, How do you tell if you need new injectors or just new o rings?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-02-2012, 08:05 PM
Member
 

Join Date: Dec 2007
Location: Spring Branch TX
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Find the leak?


Travis T
Sent from my phone...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors