My 1999 7.3 sneezes ??? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-22-2012, 12:02 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My 1999 7.3 sneezes ???

Background - 1999 7.3 manual trans. 170,000 miles. Last week the CPS failed and I replaced it. Ran fine. After a few days while going down the road the truck "sneezed", like you turned the key off and right back on, like a hiccup. The check engine light came on, but went right back off.I suspected a bad CPS, since I just changed it, and replaced it again, along with the fuel filter. New tank of fuel and a can of Sea Foam installed. Ran fine a few more days, so I took it on a 400 mile trip. Ran great for the next tank and a half of fuel (600 miles). Headed back home and it "sneezed" several times in a row, and the check engine light came on and stayed on. Drove home, 400 miles with no problem and a block from the house, more "sneezes". Any ideas? I haved had the codes read, and the next morning when I started it, the check engine light was off. ????
K4RTE is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-22-2012, 12:48 PM
Member
 
Cml390's Avatar
 
Join Date: May 2012
Location: Ajo, AZ
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the ICP sensor. Had the same problem on my 94. Try to check any stored diagnostic codes. I had no check engine light on, no stored codes, so I had to drive around with the scanner until it faulted, and checked data screen immediately.

Last edited by Cml390; 05-22-2012 at 05:43 PM.
Cml390 is offline  
post #3 of 4 Old 05-23-2012, 07:21 AM
Powerstroke.org Fanatic
 
Join Date: Apr 2012
Posts: 109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what cps are you using
2000f2507.3l is offline  
post #4 of 4 Old 05-23-2012, 08:34 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Both "new" CPS came from the Advance Auto store. 2 different stores, but close enough that I'm sure they came from the same lot. I had the codes run by my mechanic using his Cornwall brand scanner, both key off and key on. The codes it gave were for CPS failure and CPS intermittent. No codes were reset inbetween chancing the CPS either time, so the codes could also be old. I had not had any sneezing problems prior to the initial CPS failure, so I bought the grey CPS from the Ford dealer and I'll try that one and see if the problem goes away.
K4RTE is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome