99 F-550 7.3L Diesel Crank NO START - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-07-2012, 06:00 AM
Powerstroke.org Rookie
 

Join Date: Oct 2011
Location: Franklin, PA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 F-550 7.3L Diesel Crank NO START

My dad just bought a wrecked 99 F-550 dump truck. It sustained a pretty violent hit, Driver side front, pretty sure the truck went into a ditch at a high rate of speed.

At any rate the engine will crank but will refuse to start. We have the batteries charged up, reading 12 volts on each. All fuses are good. We have fuel to the filter in the V of the engine and the transfer pump is working (lines are primed from the tank to the motor). The fuel coming up to the filter seems to be completely normal, no water or bad smell to it. I pulled the mangled driver side front fender off to expose the Injector control module, it was intact, no cut wires, no evidence of the case being cracked but we are pretty sure that when the truck wrecked that module took a pretty good hit, matching up a big smash mark on the fender directly to the module.

Am I missing anything ? and Could a hit to that control module cause internal damage that u cannot see. Also the inertia switch did not trip, the button is in the down position.

Any comments would be appreciated.

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-07-2012, 03:54 PM
Powerstroke.org Rookie
 

Join Date: May 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does the "wait to start" light come on?
Reply With Quote Quick reply to this message
  #3  
Old 05-07-2012, 04:45 PM
Premium Member
 

Join Date: Apr 2011
Location: Baton Rouge
Posts: 1,127
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Does it smoke when you turn it over? Do you have oil pressure?
Reply With Quote Quick reply to this message
  #4  
Old 05-08-2012, 04:45 AM
Powerstroke.org Rookie
 

Join Date: Oct 2011
Location: Franklin, PA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No white smoke while cranking the engine, the wait to start light does come on and you can hear the solenoids clicking on. Going off the oil psi gauge on the dash it does not move when you turn it over, the gauge could be bad, not sure. I don't have a scanner to read oil psi off the HPOP.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:50 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors